Anzahl verschiedener Werte in einem Bereich in Excel ermitteln

Um in Excel die Anzahl verschiedener Werte in einem Bereich (Zeile, Spalte, was auch immer) herauszufinden, kann folgende kurze Formel verwendet werden:

{=SUMME(1/ZÄHLENWENN(bereich;bereich))}

Dabei ist bereich durch den gewünschten Bereich (z.B. A1:A20) zu ersetzen. Die geschweiften Klammern um die Formel bedeuten, dass es sich um eine Feldfunktion handelt. Die Formel einfach ohne die Klammern eingeben und die Eingabe mit STRG-SHIFT-ENTER abschließen, anstatt wie normalerweise einfach mit ENTER.

Je nach Anzahl der zu durchsuchenden Zellen kann die Formel eine Weile brauchen, bis sie das Ergebnis anzeigt. Sie führt eine Anzahl an Operationen durch, die der quadratischen Feldanzahl im angegebenen Bereich entspricht (also für A1:A20 400 Operationen).

Über uns Stefan

Polyglot Clean Code Developer

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

To create code blocks or other preformatted text, indent by four spaces:

    This will be displayed in a monospaced font. The first four 
    spaces will be stripped off, but all other whitespace
    will be preserved.
    
    Markdown is turned off in code blocks:
     [This is not a link](http://example.com)

To create not a block, but an inline code span, use backticks:

Here is some inline `code`.

For more help see http://daringfireball.net/projects/markdown/syntax