Excel-Arbeitsmappe lässt sich nicht vergrößern oder verkleinern

Heute hatte ich ein nettes kleines Problemchen mit Excel: Die geöffnete Arbeitsmappe konnte nicht vergrößert oder verkleinert werden. Oder überhaupt verschoben. Sie war einfach „eingefroren“. Das Problem bestand nur mit einer einzigen Arbeitsmappe, nicht mit allen. Weder ein Doppelklick auf die Titelleiste funktionierte, noch wurde der Größenänderungscursor eingeblendet, wenn ich…

Weiterlesen…

Excel: Blattschutz für alle Tabellenblätter aufheben

Mein Kollege hatte heute das Problem, dass alle Tabellenblätter einer (sehr großen) Excel-Datei aus Versehen geschützt wurden. Mit diesem Makro konnte ich den Blattschutz in der gesamten Datei aber recht schnell wieder aufheben: Sub BlattschutzFuerAlleTabellenblaetterAufheben() Dim i As Integer For i = 1 To Sheets.Count Sheets(i).Unprotect Password:=“geheim“ Next i End…

Weiterlesen…

Excel 2007/2010: Menü Daten (und weitere) komplett ausgegraut

Heute hatte ich das seltsame Problem, dass bei einer Excel-Datei das komplette Menü „Daten“ und weitere Funktionen (insb. auch AutoFilter) ausgegraut waren: Die Lösung war so einfach wie seltsam: Es waren zwei Tabellenblätter gleichzeitig ausgewählt (durch Klicken mit gedrückter STRG-Taste): Diese Auswahl wurde auch beim Speichern der Datei mitgespeichert, sodass…

Weiterlesen…

Excel: Beim Drucken den aktuellen Benutzernamen in die Fußzeile eintragen

Wir haben eine kleine Excel-Anwendung, deren Ergebnisse ab und an mal ausgedruckt werden müssen. Dabei soll jedoch ersichtlich sein, welcher konkrete Benutzer die Ergebnisse ausgedruckt hat. Daher soll bei jedem Druck der Benutzername des aktuell angemeldeten Benutzers in die Fußzeile des Excel-Dokuments eingetragen werden. Mit einem kleinen Makro, das man…

Weiterlesen…

Vergleich der Makro-Performance zwischen Excel 2003 und 2007

Ich setze häufig Excel-Makros ein, wenn ich „mal schnell“ CSV-Dateien bearbeiten, vergleichen oder auswerten muss. Ein Beispiel ist die Prüfung von Berechnungsergebnissen in mehreren großen CSV-Dateien. Dabei werden die CSV-Dateien eingelesen und zeilenweise in ein Excel-Arbeitsblatt eingefügt, das dann bestimmte Berechnungen durchführt und deren Ergebnisse zurückgibt. Diese Ergebnisse werden dann…

Weiterlesen…

XML-Export aus Excel: Namespace-Präfix ’ns1′ durch eigenes Präfix ersetzen

Beim Exportieren von Daten aus Excel in eine XML-Datei werden für die enthaltenen XML-Namespaces standardmäßig Präfixe der Form ns1, ns2 … verwendet (siehe Export von XML-Daten). In einer XML-Datei benötigte ich nun aber ein eigenes Präfix, da Natural leider nicht ohne Weiteres mit XML-Namespaces umgehen kann und die Präfixe hart…

Weiterlesen…

Anzahl verschiedener Werte in einem Bereich in Excel ermitteln

Um in Excel die Anzahl verschiedener Werte in einem Bereich (Zeile, Spalte, was auch immer) herauszufinden, kann folgende kurze Formel verwendet werden: {=SUMME(1/ZÄHLENWENN(bereich;bereich))} Dabei ist bereich durch den gewünschten Bereich (z.B. A1:A20) zu ersetzen. Die geschweiften Klammern um die Formel bedeuten, dass es sich um eine Feldfunktion handelt. Die Formel…

Weiterlesen…